Tuesday, November 4, 2014

New Ruby stacks with latest Ruby and Rails versions

New versions of Ruby and Rails have been released recently that address several security issues:

- Rails: CVE-2014-7818
- Rails: CVE-2014-7819
- Ruby: CVE-2014-8080
- Ruby: Changed default settings of ext/openssl

If you are using Ruby stack for deploying your application, we strongly suggest to upgrade Rails to the latest version. We have released new versions of Ruby Stack native installers (all platforms), virtual machines and cloud images for the following platforms:

- Ruby Stack 2.0.0: with Ruby 2.0.0-p594 and Rails 4.1.7
- Ruby Stack 2.1.4: with Ruby 2.1.4 and Rails 4.1.7

We continue working on the new Ruby 1.9.3-p550 version with the latest Rails 3.2.20 that will be released soon.

In addition to the base Ruby runtime and libraries, the stack includes the most popular gems for building Rails applications: Passenger, Nokogiri, Rake, RMagick, Thin and more. It also includes the latest stable release of Ruby, RVM, Rails, Apache, Nginx, MySQL, PostgreSQL, SQLite, Git, Sphinx, PHP, phpMyAdmin and phpPgAdmin.

If you have any question about Bitnami RubyStack you can check our quick start guide or you can create a new thread in our community forums.

No comments:

Post a Comment

Please use our community forum if you have any questions community.bitnami.com